Supported Web Browsers

The City of Tamarac secures its credit card payment sites using encryption, which you may recognize by the "https" in the URL (i.e. https://www.tamarac.org).  The encryption is referred to as SSL and/or TLS.  There are multiple versions of SSL and TLS, some of which are older and less secure.  Credit card payment standards (PCI Compliance Standards) require that TLS 1.0 and 1.1 no longer be used for secure communications.

As of June 17, 2018, support for the end-of-life TLS encryption versions 1.0 and 1.1 has been disabled. While we expect this change to have minimal impact, there is a possibility this change will affect some customers who may be using older web browsers.

The following are Supported Web Browsers (which support TLS version 1.2 encryption):
• Google Chrome (version greater than v.30)
• Mozilla Firefox (version greater than v.27)
• Microsoft Internet Explorer (version greater than v10 (2013))
• Microsoft Edge (all versions)
• Apple Safari (version greater than v.7)

In order to use the City's credit card payment sites, you will need to ensure TLS version 1.2 is enabled.

To check the encryption settings in Microsoft Internet Explorer browser, you can perform the following steps:
1. Open Internet Explorer
2. From the menu bar, click Tools > Internet Options > Advanced tab
3. Scroll down to Security category, manually check the option box for Use TLS 1.2